[Nestedvm] Problem with gcc 3.3.6

Andre Pietsch andre.pietsch at advicio-servdesk.de
Tue May 10 10:34:58 EDT 2011


I tried to compile nestedVM under cygwin and it worked. Because of 
problems with the project I wanted to "nestVM" I had to switch to 
current ubuntu version. The checkout and start of the compilation worked 
but I get the following error:

In file included from /usr/include/fcntl.h:252,
                  from ../../gcc-3.3.6/gcc/system.h:208,
                  from ../../gcc-3.3.6/gcc/collect2.c:30:
In function "open",
     inlined from "collect_execute" at ../../gcc-3.3.6/gcc/collect2.c:1575:
/usr/include/bits/fcntl2.h:51: error: call to "__open_missing_mode" 
declared with attribute error: open with O_CREAT in second argument 
needs 3 arguments
make[3]: *** [collect2.o] Error 1
make[3]: Leaving directory 
make[2]: *** [all-gcc] Error 2
make[2]: Leaving directory 
make[1]: *** [tasks/build_gcc] Error 2
make[1]: Leaving directory `/home/andrepietsch/software/nestedvm/upstream'
make: *** [upstream/tasks/build_gcc] Error 2

Has anyone a clue what that means?

Andre Pietsch
Tel.: +49 351 3329139
Mobil: +49 176 55052270
Email: andre.pietsch at a-sd.de
Advicio Servdesk GmbH
Pohlandstr. 17, D-01309 Dresden
Geschäftsführer: Roland Laqua
Amtsgericht Dresden, HRB 25330, USt-IdNr. DE252872908

More information about the Nestedvm mailing list