[Nestedvm] Some problems with current Cygwin

Andre Pietsch andre.pietsch at advicio-servdesk.de
Tue May 3 09:47:50 EDT 2011


I hope this list is still active because nothing happened here since 2010.

I have some trouble with nestedVM and cygwin. I try to compile some C++ 
code (.cpp files) with it. When I call the mips-unknown-elf-gcc I get 
the message that C++ is not installed on the system. I also tried the 
mips-unknown-elf-cpp with the same message.

But I am sure that I installed all needed g++ stuff on that cygwin 
installation. the make runs (for about 2h) wothout a visible error 
message. If I look into the nestedVM build and download folders there is 
also the stuff needed for its compilation and the own g++ 3.3.6. I tried 
to add the paths to those compiled parts to my PATH variable in the 
env.sh script for the cygwin console but without success. I also tried 
to change the CXX variable from mips-unknown-elf-g++ to 
mips-unknown-elf-cpp because this is the only elf I have found that made 
sense at this point.

So if there is anybody out there who can help I would appreciate it.

Kind regards

Andre Pietsch
Andre Pietsch
Tel.: +49 351 3329139
Mobil: +49 176 55052270
Email: andre.pietsch at a-sd.de
Advicio Servdesk GmbH
Pohlandstr. 17, D-01309 Dresden
Geschäftsführer: Roland Laqua
Amtsgericht Dresden, HRB 25330, USt-IdNr. DE252872908

More information about the Nestedvm mailing list